The next job that needed to be immediately done after the new exhaust manifold were the coolant hoses.

The new manifold design is bigger which makes it press up against the top radiator hose, not ideal! So another message to Dynodaze for some Forge Silicone hoses (now discontinued)

What I didn't mention in the video was the painful process of bleeding the coolant. After topping up the radiator I struggled to get the radiator fan to come on. The first attempt was an hour long, surely it would come on by then?!

I left it to cool down and came inside for abit. I then went back outside at 7pm and was out there till 8:30pm and STILL no radiator fan?!

The next day I left for work abit earlier than normal and had a friend come over to help look at it as I was unable to.

The fuse and relays were checked and tested. With a diagnostic machine plugged in the coolant temp was monitored. It reached 97deg but still no fan, not good! Both hoses were hot so that ruled out the thermostat.

I spoke to my local garage H&S Performance and they mentioned some cars do need to be over 100deg before the fan kicked in. I said to my friend to take it to 103deg and if it still didn't work then I'd have to find a wiring diagram and see if we can power on the fan ourselves.

At 100.7 degrees the fan FINALLY span into life and switched off at 95 degrees. Strange. I'm just glad it works and I can drive without worry.

WANT TO GET SOME MORE?

Send us your email address and we’ll send you great content!

You've successfully subscribed to Combustionpunks
Great! Next, complete checkout for full access to Combustionpunks
Welcome back! You've successfully signed in
Success! Your account is fully activated, you now have access to all content.
Unable to sign you in. Please try again.
Success! Your account is fully activated, you now have access to all content.
Success! Your billing info is updated.
Billing info update failed.
Your link has expired.
Become a Patron!